4000 258 365
用户名:
密码:
忘记密码? 尚未注册?
邮箱地址:
密码:
确认密码:
手机:
单位:
注册

已知思科ASA设备漏洞仍在其新版本中存在

作者:中关村在线(北京) 发布时间:2016-08-29

近日,名为“Shadow Brokers(影子经纪人)”的黑客组织声称成功入侵了跟NSA相关的Equation Group(方程式组织)的计算机系统,并成功窃取到了大量的机密信息以及黑客工具。随后,“Shadow Brokers”黑客组织将60%的泄漏文件在网上进行了公布,其中就包含有针对多款网络设备的漏洞利用代码。

据悉,目前Shadow Brokers已经释放了大约300Mb的防火墙漏洞利用、植入和工具代码。而据安全公司和斯诺登泄露的文件显示这些代码是真实的,专家更指出,最近的文件可以追溯到2013年。

这些漏洞利用、植入和工具代码专门针对Cisco、Fortinet、WatchGuard、Juniper Networks和其他供应商的产品。这些公司都已经对泄漏的代码进行了分析,但到目前为止,只有思科发现了一个之前未发现的漏洞(CVE-2016-6366,CNNVD编号为CNNVD-201608-012)。

这个漏洞能够影响思科自适应安全设备(ASA)软件的简单网络管理协议(SNMP)代码,拥有目标系统访问权限的远程攻击者可以利用这个漏洞执行任意代码,并获得设备的完全控制权。思科尚未发布一个安全漏洞的补丁,但它提供了一些解决方法。

泄露的CVE-2016-6366漏洞的利用代码,被称为“EXTRABACON”,已经有几年历史了,所以只能在旧版本的ASA上正常工作。思科公司的安全专家表示已经修复了这个漏洞,并且表示只要用户运行的是最新版本的思科软件,那么他们就不会受到“Shadow Brokers”事件的影响。

然而, 研究人员近日证明了泄露的思科ASA漏洞利用也可以在新版本的软件上进行远程代码执行。

研究人员设法修改了泄露的ASA漏洞利用代码,并将其应用到了版本ASA 9.2(4)上,该版本于2015年7月发布。

此外,安全专家Balint Varga-Perke称,泄露的漏洞利用代码甚至可以应用到更新的版本上。安全公司正在为目前不支持的思科ASA版本自动生成利用代码。修改ASA漏洞利用代码并将其应用到版本ASA 9.2(4)只花费了研究人员几个小时。

“不幸的是,一些人只有在看到实际的演示之后才会认识到漏洞的风险,”Varga-Perke在一封电子邮件中说到。“我们希望我们的开发也能够让那些持怀疑论的人们认识到这些风险。”

根据思科针对CVE-2016-6366漏洞做出的安全公告,该漏洞影响所有ASA的软件版本和所有支持SNMP的版本。当供应商在一个运行版本9.4(1)的思科ASA 5506设备上测试泄露的漏洞利用代码时,软件崩溃了。

思科产品安全事件响应团队的Omar Santos也证实,漏洞利用代码经过修改可以应用到任何ASA代码上。

目前还不清楚Shadow Brokers的幕后推手是谁。虽然有怀疑是俄罗斯黑客所为,但也有人认为是一个国家安全局(NSA)内部人员所为。


分享到:
北京安华金和科技有限公司 ©2015 版权所有 ICP备10053980号 京公网安备11010802010569号